Reply To: updates

HomeForumsGeneral DiscussionupdatesReply To: updates

Author Replies
QuickMythril # Posted on 2012-01-28 at 05:05PM UTC
avatar

you should be fine with 2.0 until a new game comes out that you want to play that requires you to update your dash. once you update to 14699 you will need to have LT+ 3.0