After Dash updates Drive refuses to play even retail games!

HomeForumsGeneral DiscussionAfter Dash updates Drive refuses to play even retail games!

This topic has 6 voices, contains 14 replies, and was last updated by avatar SSimon 1736 days ago.

Viewing 10 posts - 1 through 10 (of 15 total)
Author Posts
Author Posts
2012-02-23 at 09:06PM UTC #6265
avatar
SSimon

Hey guys,

I have a phat xbox360 Elite which came with a Hitachi 79FL DVD drive. That drive failed about 4 years ago and was replaced with a BenQ. As of last year MS started doing drive and AP checks so I reverted to a Hitachi 79FL making sure it matched 100% the original (I had saved the key & all info). Before I did the dash updates I restored the Hitachi drive to stock, loaded my key and ensured the model, memory address and even the checksum matched 100% what I had saved in the bin file from the original drive.

However the new Hitachi (as stock) refuses to play even retail games. It says “Play DVD” and displays an Xbox 360 logo!

When flashed with Hitachi LT+ 2.0b it behaves the same with retail games. Backups say “Play Game” but when you launch, nothing happens and the dash comes right back!

Any suggestions/ideas? I am stuck with an usable xbox!

2012-02-23 at 10:39PM UTC #6270
avatar
Andy1066

Have you got Drive key as u would get this response with the wrong drive key flashed to your new drive

2012-02-23 at 11:47PM UTC #6271
avatar
SSimon

Hey Andy, YEAH, same key I was using on the replacement BenQ for several years. I had saved the original .bin and key files from the Hitachi that came with this xbox and did a dump to verify on the replacement Hitachi that all is 100% correct and matching down to the checksum. That’s why this is driving me crazy!

2012-02-24 at 12:32PM UTC #6272
avatar
QuickMythril

could be a bad laser. also i would try a different drive with your dvd key to make sure it is correct. maybe even a non-ap2.5 xgd2 game in the benq. if it said play game sometimes and not play dvd then i would guess the key is ok. so try the laser pot tweak and if that doesn’t work replace the laser.

2012-02-24 at 09:36PM UTC #6277
avatar
SSimon

Hi QuickMythril, good points, thanks.

I was so frustrated I gave up on “XBL Stealth” and even flashed the previous BenQ with LT+ 3.0, but got EXACTLY the same issue! I then flashed the BenQ to stock and tried. SAME “Play DVD” ISSUE. I was thinking about the laser on the “new” Hitachi 79FL, but if so why would the BenQ not work in either LT 3.0 or stock?

For reference, the Retail game I tried was the Kinect Adventures title, which I believe is [Wave 13] and non-AP 2.5, so it should have worked…

2012-02-25 at 12:21AM UTC #6278
avatar
QuickMythril

“play dvd” always happens when you have the wrong key. (but it can also be a bad disc or laser.) are you positive you didn’t get the original firmware files mixed up somehow? but you said sometimes it says “play game” which i don’t think is even possible with the wrong key…so that’s confusing.

2012-02-25 at 04:57AM UTC #6283
avatar
QuickMythril

i have some news for you. someone in irc was having a similar issue. and i did some testing and found that xgd2 games will say Play DVD with the wrong key, but xgd3 games will say Play Game, and not boot. which is what you said happens. so i am thinking it’s probably a wrong dvd key. check all your firmware files and see if some have different keys someplace. maybe you mixed something up. if the key really is gone, then you’d have to rgh it to get the key back. i could do the key retrieval for you if it’s not a xenon and you are willing to pay shipping.

2012-02-25 at 05:37PM UTC #6288
avatar
SSimon

Hi QuickMythril,

I have both the saved stock firmware and the key.bin file from the original Hitachi 79FL and that is all I have been using, so I fail to see how the key could have been mixed up, unless somehow they got corrupt or something happened to the xbox itself during the dash updates. Below is a screenshot of the “new” Hitachi drive as source and the original Hitachi firmware as target in latest JF. Do they look mismatched in any way?

“Play DVD” comes on with both the BenQ and then new Hitachi in Stock mode using the Retail XDG2 Kinect game, and “Play Game” comes on with both when using LT+3.0 and 2.0b respectively with an XGD3 backup but of course, neither really works.

Guess I will try again to flash the new Hitachi with the saved stock files and see what happens. If that fails I may have to take you up on your offer but my Dash is 14699 and this is a 2008 Elite model (2008-01-17) w/ HDMI so I am unsure if you can do anything with it to extract the key… What do you think?

  • This reply was modified 1743 days ago by avatar SSimon.
2012-02-25 at 11:27PM UTC #6293
avatar
richy76

As quick says i have even had an xgd3 game do an update to the dash in an xbox with the wrong key that some idiot give me to try & fix, it never booted the game though.

  • This reply was modified 1743 days ago by avatar richy76.
2012-02-26 at 02:06AM UTC #6295
avatar
zack

dude blur out your key on the image LOL :lol:

Viewing 10 posts - 1 through 10 (of 15 total)

You must be logged in to reply to this topic.