any point updating samsung lt 2.01 to 3.0?

HomeForumsGeneral Discussionany point updating samsung lt 2.01 to 3.0?

This topic has 7 voices, contains 9 replies, and was last updated by avatar Bringer 2172 days ago.

Viewing 10 posts - 1 through 10 (of 10 total)
Author Posts
Author Posts
2011-12-06 at 04:59PM UTC #4806
avatar
mick500

hi, just wondering if its necessary to update my samsung drive 360 with lt2.01 to lt 3.0 when it comes out since it doesnt fail the ap2.5 challenges and everything is working fine? sorry if its a dumb question, i just dont see the need for updating the sammy’s unless im missing something? thanks.

2011-12-06 at 06:23PM UTC #4808
avatar
QuickMythril

i assume you won’t need to reburn your discs with a samsung, nor update the firmware, but if you have a disc burned with topology data you may need to have 3.0 to be able to boot that disc. even though i would imagine that the samsung drive would just ignore the topology data the same way it ignores the ap2.5 data. no way to know for sure until the firmware is released. i wouldn’t really worry about it. you have the best situation right now with a samsung drive.

2011-12-07 at 05:18AM UTC #4833
avatar
thugzbaby

well i thought so too,but i’ve just updated my dashboard and now i get a “can’t authorize game” message when I try to play. So something has changed in the dashboard, so we might see 4.0 soon or a revamp of 3.0.

You will only need 3.0 if you try to play a game that was backed up with a 3.0 format iso. If you backup your own games and use the correct software to make 2.0 format then you will be fine. But like I said I have samsung and now i get error message after I updated my dash. So we may all be forced to update our drives

2011-12-10 at 11:37PM UTC #4976
avatar
betaRepeating

There’s no 3.0 announced for Samsungs on the front page. So logically… <_<

2011-12-11 at 05:55AM UTC #4980
avatar
Daileyyy

Samsungs and hitachi 59 and before CANNOT read AP2.5 data, no newer firmware is needed for these drives at the time so there will be no expected 3.0 for these drives. No need to reburn games for these drives I stated.

2011-12-12 at 08:58AM UTC #5000
avatar
abyss

Does this mean I play my games with only the 2.0 update?

2011-12-12 at 10:33AM UTC #5001
avatar
QuickMythril

yes

2011-12-13 at 11:02AM UTC #5034
avatar
Bringer

No 3.0 for the Samsung?! This makes me angry…. I have 3 Samsung drives…. And I want to play “Hunted”…

:cry:

2011-12-13 at 02:10PM UTC #5042
avatar
QuickMythril

you don’t need 3.0, you can play Hunted or any game, offline or online, using 2.01

2011-12-14 at 10:05AM UTC #5063
avatar
Bringer

No, I Can´t! The english Version is running without Problems. The german Version gives me the “Can´t read Disc” message!
ABGX used! Burned 2x!

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.