BenQ not reading XDG3 games

HomeForumsGeneral DiscussionBenQ not reading XDG3 games

This topic has 4 voices, contains 3 replies, and was last updated by avatar jailer69 1070 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
Author Posts
Author Posts
2013-11-15 at 12:09AM UTC #8810
avatar
thugzbaby

Hi,

I have a phat Xbox 360 which originally had a Toshiba Samsung drive in it. The drive went bad so I got ahold of another Xbox and found that it had a BenQ drive in it. So I flashed it with LT+ 3.0. The Benq can only play originals and XGD2 backups. When I put in an XGD3 backup my Xbox resets and comes up to the E66 error screen.

I burned the XGD3 game using BMP v0.15 and an Asus DVD burner. I’m using Kodak DL DVD’s.

I want to know if there is a known reason for the BenQ not to read XGD3 games? I also read that the BenQ could read XGD3 truncated backups so I burnt one and tried it and still got the reset E66 error.

If anyone has any advice please respond.

Thanks.

2013-12-13 at 02:59AM UTC #8832
avatar
SoloG

Have you tried to flash the drive back to stock then back to LT+3.0? Also Verbatim DL DVD’s should be used for XGD3 backups.

2013-12-13 at 06:06PM UTC #8835
avatar
QuickMythril

because your xbox expects to have a drive that does NOT do ap2.5 checks, such as a samsung or older hitachi. the benq, liteon, and newer hitachi drives all do the checks. when your benq tries to do a check on the xgd3 discs it causes an issue with the xbox. find another samsung or older hitachi and use that and you won’t have that problem anymore.

2014-01-03 at 01:12PM UTC #8842
avatar
jailer69

I have had a similar issue, when LT3+ came out you stopped being able to spoof drives so you need to get yourself the same model as your original drive in this case “Toshiba Samsung”. This was true when I had the issue when LT3+ first came out :) if anyone knows different please comment :D

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.