Weird XDG3 problems

HomeForumsGeneral DiscussionWeird XDG3 problems

This topic has 3 voices, contains 3 replies, and was last updated by avatar laxity 1409 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
Author Posts
Author Posts
2013-01-19 at 03:26PM UTC #8416
avatar
laxity

Ok, I have just about given up with this so I am really hoping someone here might be able to help figure out what is going on.

Setup is :

- Xbox 360 Phat with dashboard 16202

- REAL Samsung MS28 (*NOT* Spoofed) with the latest iXtreme firmware LT+ v2.01 (3.x is not available for Sammys before anyone mentions upgrading)

The problem I have is that all XDG3 games either ORIGINAL or BACKUPS fail to start with an error :

“Unrecognized Disc”

“This disc is unreadable”

All NON-XGD3 games work perfectly whether they are originals or backups.

So far I have tried the following :

1. Cleared cache (also tried removing HDD)

2. Flashed to stock Samsung MS28 firmware – problem is the same with original discs. XDG3 games don’t work and non-XDG3 games are fine.

3. Re-flashed LT+ 2.01 from another download source (to ensure not corrupt or bad flash)

4. Performed multiple POT tweaks on drive laser – problem remains

5. Replaced the drive laser with a brand new MS28 laser – problem remains

6. Replaced the Samsung MS28 DVD drive with a brand new one and flashed my original key – problem remains with either stock or LT+ firmware.

7. POT teaked new MS28 drive as a last resort – problem remains

XGD3 ORIGINAL games that fail :

- Halo 4
- Assassin’s Creed 3
- NBA 2K13
- Need for Speed Most Wanted

All games will install to HDD fine but fail during the initial disc check (copy protection I guess)

As mentioned earlier, ALL NON XDG3 games work fine regardless if they are Original or Backups.

As I have tried a new laser and a new drive this can’t possibly be a DVD drive hardware problem.

I can’t see how its a firmware problem either if Stock firmware fails too and also non-XDG3 games work fine.

Does anyone have any ideas what is going on here or anything I might have missed?

This is seriously driving me nuts!

Thanks :)

2013-01-20 at 06:16PM UTC #8421
avatar
QuickMythril

i would suggest trying another drive that does ap2.5 checks if you have a benq or liteon you can use to test it out. i am thinking maybe your xbox didn’t have a samsung drive in it originally? unless you know for sure that you received it new and never changed the drive. even so perhaps the console got switched around with another one that you thought was new. who knows? at this point seeing all that you have tried, that would be my last resort attempt to determine a solution.

2013-01-24 at 12:34PM UTC #8427
avatar
Chefren

Try replace SATA cable.
Which motherboard you have? If it’s falcon you must benq or liteon like Quick Mythrill said.

2013-01-24 at 08:17PM UTC #8428
avatar
laxity

Thanks guys. Finally solved. I discovered from my old jungleflasher logs that it came with a Samsung MS28 spoofed as a Liteon back in 2008 when I bought it pre-flashed. It must have had a true Liteon drive originally and was swapped for an MS28 and spoofed. At some point in 2009 I flashed it back to a true Samsung MS28 drive again (i.e. I unspoofed it) because I didn’t understand the reasoning back then of why that had been done.

It has been fine ever since running with a real Samsung MS28 with iXtreme and then LT+ etc until XDG3 came along and backups no longer worked due to the AP2.5 checks failing.

Now that I have put a Liteon back in the system after so long I suppose I now run a big risk of a ban but not much I can do about that now I guess. lol

Many thanks for your help.

  • This reply was modified 1409 days ago by avatar laxity.
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.